Forum zum WebKicks.De Chatsystem Foren-Übersicht Forum zum WebKicks.De Chatsystem
Support-Forum zum WebKicks-Chatsystem
 
 FAQFAQ   SuchenSuchen   MitgliederlisteMitgliederliste   BenutzergruppenBenutzergruppen   RegistrierenRegistrieren 
 ProfilProfil   Einloggen, um private Nachrichten zu lesenEinloggen, um private Nachrichten zu lesen   LoginLogin 

Dieses Forum dient als Archiv, es können keine neuen Beiträge eröffnet werden.

Hier geht es zum neuen Webkicks Forum
.

[BETA 1] MaiZ-ChatBot-System
Gehe zu Seite Zurück  1, 2, 3 ... , 37, 38, 39  Weiter
 
Neues Thema eröffnen   Neue Antwort erstellen    Forum zum WebKicks.De Chatsystem Foren-Übersicht -> Bots, Chat-Games
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
fan34


Verwarnung

Anmeldedatum: 30.07.2008
Beiträge: 250

BeitragVerfasst am: 14.02.2009, 20:45    Titel: Antworten mit Zitat

Hamigra, ich habe kein Zitat zu Dir gemacht. Smilie

/Edit: Eigenlich sollte ich den gleichen Beitrag jetzt an Dich senden!
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen
DarkModi




Anmeldedatum: 08.05.2005
Beiträge: 1969

BeitragVerfasst am: 14.02.2009, 21:46    Titel: Antworten mit Zitat

@hamigra: sicher dass alle Scripts beim Test raus waren? Bei deinem Screen sind ja definitiv Scripts eingebaut.

Wurde der Chat vielleicht in einem Frame eingebunden?
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
hamigra




Anmeldedatum: 31.08.2006
Beiträge: 1601
Wohnort: Werdau

BeitragVerfasst am: 14.02.2009, 23:03    Titel: Antworten mit Zitat

Bei dem Screenshot waren die Scripte noch drin, deshalb schrieb ich ja, daß auch nach der Leerung der Ankündigung keine Änderung eingetreten ist.
Nein - der Chat ist nicht in einem Frame.
Ich vergaß allerdings zu erwähnen, daß ich die Befehle (bzw. die Wörter, auf die der Maiz reagiert) über eine eingebundene Seite (analog einer eigenen Smilieseite) in den Chat sende. In den anderen Chats klappt das ja auch bestens.
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen
DarkModi




Anmeldedatum: 08.05.2005
Beiträge: 1969

BeitragVerfasst am: 14.02.2009, 23:15    Titel: Antworten mit Zitat

hamigra hat Folgendes geschrieben:
Ich vergaß allerdings zu erwähnen, daß ich die Befehle (bzw. die Wörter, auf die der Maiz reagiert) über eine eingebundene Seite (analog einer eigenen Smilieseite) in den Chat sende. In den anderen Chats klappt das ja auch bestens.


Ist die Adresse dieser Seite dieselbe wie die, die in der Fehlermeldung angezeigt wird?
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
hamigra




Anmeldedatum: 31.08.2006
Beiträge: 1601
Wohnort: Werdau

BeitragVerfasst am: 15.02.2009, 07:47    Titel: Antworten mit Zitat

Problem gefunden - Es lag an der Befehls.htm, in die sich ein falscher 'onclick' eingeschlichen hatte.
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen
karinsch




Anmeldedatum: 02.12.2007
Beiträge: 69

BeitragVerfasst am: 16.02.2009, 14:42    Titel: Bot reagiert nicht...? Antworten mit Zitat

Hallo!

Ich hab jetzt versucht maiZ in meinem Chat zu intergrieren.
Ich hab dafür die 2 .js-Dateien (http://www.wkforum.de/viewtopic.php?p=99709#99709) erstellt und auf meinen Server geladen.
Das einzige was ich verändert habe, ist die BOT-NAMENSGEBUNG.
Ich hab dann die beiden .js-Dateien in der Ankündigung für reg. Chatter reingeschrieben:
<script type="text/javascript" src="URL VON DATEI 1"></script><script type="text/javascript" src="URL VON DATEI 2"></script><script type="text/javascript">startStreamer(%chats%);</script>

Der Chatbot wird mir in der Chatterliste auch angezeigt. Aber er reagiert nicht....?
Wenn ich als reg. Chatter einsteige und eingebe "hi" müsste er ja zurückschreiben: "hi &user&! Smilie"
Oder?
Oder muss ich auf nochwas achten, dass der Bot reagiert?
Fehlermeldung bekomm ich keine, er reagiert nur nicht....?

Bitte um Hilfe!
Vielen Dank im Voraus!
Liebe Grüße,
Karin!
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
hamigra




Anmeldedatum: 31.08.2006
Beiträge: 1601
Wohnort: Werdau

BeitragVerfasst am: 16.02.2009, 17:46    Titel: Antworten mit Zitat

Link zur maiz2.js wäre hilfreich denn normalerweise müßtest du eingeben hi maizname denn ansonsten reagiert er auf jedes wort in dem hi vorkommt Winken
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen
karinsch




Anmeldedatum: 02.12.2007
Beiträge: 69

BeitragVerfasst am: 16.02.2009, 18:20    Titel: Antworten mit Zitat

Wie gesagt, liegt das script auf meinem eigenen Server. Ich poste mal den Link dorthin - hoffe das ist okay:
---
Und heissen tut der Chatbot "bobo" Smilie
In der Chatterliste taucht er auf, aber reagieren tut er irgendwie nicht...
Bin jetzt nochmal als reg. Chatter eingestiegen und hab geschrieben "hi bobo" aber er hat mir nicht geantwortet...

Liebe Grüße,
Karin!


Zuletzt bearbeitet von karinsch am 16.02.2009, 20:02, insgesamt 2-mal bearbeitet
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
hamigra




Anmeldedatum: 31.08.2006
Beiträge: 1601
Wohnort: Werdau

BeitragVerfasst am: 16.02.2009, 18:29    Titel: Antworten mit Zitat

Änder mal bei dir NUR die Stelle:
Code:
/hi/i

auf
Code:
"hi"
und dann gib ein hi bobo
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen
karinsch




Anmeldedatum: 02.12.2007
Beiträge: 69

BeitragVerfasst am: 16.02.2009, 19:19    Titel: Antworten mit Zitat

Sehr glücklich Sehr glücklich
Ich hab jetzt die Grundscriptsammlung nochmal neu runtergeladen: http://www.wkforum.de/viewtopic.php?t=14238&highlight=grundscriptsammlung
Und jetzt spricht er mit mir Sehr glücklich Sehr glücklich
Muss ich wohl was drinnen gehabt haben bis jetzt, das der Chatbot nicht mochte...

Trotzdem danke für die Hilfe!
Liebe Grüße,
Karin!

Eine Frage wär da noch: funktionieren tut der Chatbot nur für registrierte Chatter, oder? Und nicht für Gäste... Weil da mags in der Ankündigung schon das %chats% nicht...
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
1. FC Keller
Moderator



Anmeldedatum: 04.07.2004
Beiträge: 4176
Wohnort: heimat:// Thüringen.Deutschland.eu/ Zeulenroda

BeitragVerfasst am: 16.02.2009, 20:37    Titel: Antworten mit Zitat

einfach den code für die Grundscriptsammlung verwenden: <script type="text/javascript" src="/grundscripts.js"></script>

dann hast du keine probleme mit der aktualität Winken
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen
karinsch




Anmeldedatum: 02.12.2007
Beiträge: 69

BeitragVerfasst am: 17.02.2009, 16:38    Titel: Antworten mit Zitat

Hallo nochmal!

2 Fragen hätt ich noch:

1.)
Ist es möglich, dass Gäste auch den Chatbot sehen bzw. mit ihm sprechen können?

2.)
Wie funktioniert das mit den Witzen? Ich hätt gerne, dass der Chatbot auf "Kommando" (also wenn ein User "!witz" eingibt) 1 Zufallswitz (aus einer Liste von Witzen) ausgibt.
In welcher .js-Datei muss ich da was genau einbauen?

Vielen Dank im Voraus!
Liebe Grüße,
Karin!
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
enteni01




Anmeldedatum: 04.04.2009
Beiträge: 4

BeitragVerfasst am: 04.04.2009, 01:35    Titel: Antworten mit Zitat

HILFE MEIN BOT ANDWORTET MIR ERST GARNICHT ER WIRD TWAR ANGEZEIGT IN DER OL ABER ER ANTWORTET NICHT
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden
enteni01




Anmeldedatum: 04.04.2009
Beiträge: 4

BeitragVerfasst am: 04.04.2009, 01:36    Titel: Re: [BETA 1] MaiZ-ChatBot-System Antworten mit Zitat

HILFE MEIN BOT WIRD IN DER OL ANGEZEIGT ABER ANTWORTET NIT WENN IHR MIR HELFEN KÖNNT DANN SCHICKT MIR NE MAIL Chillaut-@live.de
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden
TauchBlubba




Anmeldedatum: 21.10.2007
Beiträge: 1562
Wohnort: Altenstadt (Mittelhessen)

BeitragVerfasst am: 04.04.2009, 10:31    Titel: Antworten mit Zitat

Ein Beitrag sollte doch langen Winken

Und normal schreiben doch eigentlich auch, oder?

Ohne zu wissen wie deine Dateien aussehen können wir dir nicht helfen.

Grundscriptsammlung eingebaut?

grüße
Chrissi
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen
Beiträge der letzten Zeit anzeigen:   
Neues Thema eröffnen   Neue Antwort erstellen    Forum zum WebKicks.De Chatsystem Foren-Übersicht -> Bots, Chat-Games Alle Zeiten sind GMT + 2 Stunden
Gehe zu Seite Zurück  1, 2, 3 ... , 37, 38, 39  Weiter
Seite 38 von 39

 
Gehe zu:  
Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.


Powered by phpBB © 2001, 2005 phpBB Group
Deutsche Übersetzung von phpBB.de